Jump to content

Ufile stopped accepting passwords

Recommended Posts

For some reason ufile.ca does stopped accepting my passwords for any of my accounts.

When I try to "change password" it asks me for a challenge phrase.
I made those accounts a long time ago, and I am certain that I was not asked for a challenge phrase.

What gives?

I need this fix ASAP!

Share this post

Link to post
Share on other sites

Same issue. Password all of sudden stops working. Tried to reset password but email reset link is never sent. I've had no need to change email/password for almost 10yrs then this happens. Forwarded complaint to help@ufile.ca. You get nothing but a password form letter which provides ZERO help as it doesnt address my issue at all. Tried calling, puts you on hold ad nauseum for hours on end. I'm now trying support@ufile.ca... *fingers crossed* Extremely frustrating. How does a company operate like this?? 

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


© 2013 ImpôtExpert, Thomson Reuters. Tous droits réservés. Politique de confidentialité
  • Create New...