Jump to content
Français
mlevin

ERROR: invalid NAICS

Recommended Posts

Hello,

 

I've submitted the trouble ticket via the UFile, but I never got any feedback, not even the automated email.

 

For my wife I had a Self-Employed Professional Income last year, with NAICS 541510.

 

This year I added one more business, she opened last year. This time also as a Professional Income, with different NAICS 519130.

 

When producing the results, UFile shows the error:

 

NETFILE {name here}. You cannot currently NetFile your federal return...

> You entered an invalid NAICS (North American industry classification system) code for a business (self-employment). Click here to fix >[] or a T5013/T5013A slip.

 

When I click on the link, it brings me to the Business Identification page for that 2nd business.

 

Here I tried to enter a number of other NAICS codes, which might make sense, and I mean a number of them. I even tried to enter the same 541510, as for the 1st business.

 

Still, it produces the same error.

 

Please help to resolve this. It's blocking me from NetFile'ing my wife's taxes.

 

Mick.

Share this post


Link to post
Share on other sites

I *did*.

 

And as I mentioned, I tried many (as 10+) various codes, which more or less are close to the business model she runs in the 2nd business of her.

 

None worked.

 

So I need to understand, what exact condition blocks the 2nd company from being validated by NIACS. Even with the case of code, being the same as for the older 1st business of her.

 

Please advise what can you help me with in that situation.

 

Please consult the following link for the North American Industry Classification System (NAICS) Canada 2012:

 

http://www23.statcan...dm=8&TVD=118464

Share this post


Link to post
Share on other sites

*** PROBLEM SOLVED ***

 

The code of the 1st, older business, has changed in 2012.

 

THE GLITCH of the software leads me to the WRONG business record in the interview -- on a click, it brings me to the page of the new business, which has got the right code. And it has NO MENTION that the code could have changed for the OTHER business record in the interview.

 

So many trials and total re-entries of my data finally led me to the root cause of that problem.

 

Guys at UFILE - fix that link at the Results!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

© 2013 ImpôtExpert, Thomson Reuters. Tous droits réservés. Politique de confidentialité
×
×
  • Create New...