Jump to content
Français
Search In
  • More options...
Find results that contain...
Find results in...

DOWNLOAD for ufile 2021


Recommended Posts

  • 1 month later...
  • 3 weeks later...

I had purchased the UFILE 2021 software Ufile 12 for Windows. received my activation key and attempted to download the software by going to the link for Ufile for windows which was provided to me. I tried the edge (bing) browser and the google chrome browser but to no avail. They referred me to  the home page only even though I inserted the full link into the search lines. I then attempted to download the software from a posting provided by Gail 23 of Ufile support as directed to Pat Savage but to no avail. I extracted the Zip file after download but it would not work when I pressed either the setup exe or the Ufile for Windows file as noted therein.  I then attempted to contact Ufile directly on your web site  but you would not acknowledge my user name or e-mail  address. I then attempted to determine if you had my user name or password on file as I usually in the past only contact you via the specific annual software source. You indicated that I would receive an acknowledgement of my user name via a return email which I have not yet received. Your next reply on the site is to try anything!!!!  This is not acceptable!!  As I am frustrated and confused as to why the link provided to me cannot be accessed properly ( maybe because of search browsers or otherwise) I need your HELP to proceed. PLEASE provide me with a proper link that is accessable and that can be downloaded with reasonable ease. 

Paul

Link to comment
Share on other sites

By golly I did try ANYTHING and was successful in downloading the 2021 software on the very link as provided by another fellow. UREKA !!! AND i QUOTE Brian B. as follows:

Posted January 12

I had the same Not Responding problem during the 2021 install procedure, I emailed Support twice and the second time I received several links to try. 

Their last link worked: https://cdn.ufile.ca/ufile/UF2021BNGH36GHVFENB469KL3CMO9/ufile2021.zip

After I unzipped the file I clicked on the MSI file to start the install, it took a while to get going but it finally installed ok.

Just press this link. It works!!! The others are corrupt.

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...