Jump to content

Ufile2020.exe downloads, but will not Install


Recommended Posts

I've downloaded, deleted, and redownloaded Ufile2020.exe various times over the past month and tried to install on my desktop or my tablet (both running current Windows 10). Will not open or "Run as Administrator." A User since 2004, no prior issues in installations. Note: Dropdown under Ufile.exe "Properties" indicates, under "General" tab and "Description" heading..."Contact: Your Local Administrator". Download size is 72.3mb

So,... how might I go about making this a viable and operational Ufile2020.exe?

Also, I've sent 3 emails to customer service regarding this and received no response whatsoever. Not even a generic responding email to acknowledge receipt of my enquiry (along with a transcript of the query), as many other customer inquiry websites do?   

Edited by Lurch3w4
Clarification to Ufile year
Link to comment
Share on other sites

  • Lurch3w4 changed the title to Ufile2020.exe downloads, but will not Install

I have paid for the 4 Ufile for Windows 2020, received the activation code, but haven't heard from Ufile when the file is ready for download. I sent them an email but all I got was the request #. They used to be very responsive to people's queries but not this time, just wondering if the company is in financial problems. The worst scenario is lost of $20, not the end of the world.

Link to comment
Share on other sites

3 hours ago, John Moreira said:

I'm having the same problem. Tried everything I can think of, but the app won't install on my Windows 10 desktop.

I finally managed to get the install to work. Although my standard Windows 10 account has administrator privileges, the install did not work. I logged out of my standard ID and logged in using the Windows "Administrator" ID and the install worked. Looks like the install program is flawed if it won't install using a standard account.

Link to comment
Share on other sites

After various workarounds, I did manage to get the Ufile2020.exe download on to my pathetic Windows 10 tablet that I have, and through that I was able (with limitations, see below) to install Ufile2020 to my Windows 10 Desktop. Not sure exactly why it downloaded onto the tablet this time, as it had not done so in prior attempts.

How did I then download to my Desktop??... I went back to my tablet and Dropboxed the now opened Ufile 2020 file folder to my Desktop, opened the Ufile2020.exe from within the folder and ran it. Ufile2020.exe did install onto my Desktop, and appears to be functional in "most" respects. To test it, I downloaded my 2019 Tax file info into Ufile2020, and filled in some data, which it accepted. I also tried to update the Ufile2020 program, but the Ufile2020 updater will not recognise the Ufile2020 file on my system, so it will not update (not that there was an update anyway). Not being a computer whiz, I relocated the Ufile2020 program to my Program Files (x86) where it shows up if I go into Program Files (x86) , but there is still no recognition in my system (e.g. nothing showing in Settings under Apps or Uninstall), although my older Ufile2019 does show). So I can run Ufile2020 on the Desktop, it is not recognized as installed in my Windows programming, and I surmise I may have further problems down the line if it is not recognized. Next step, dump everything, try reinstalling from opened Ufile2020 folder again. 

Presently responding to 3 generic, "try these unrelated links", non-answer Ufile Support responses, all for the same subject, as I've sent 3 similar enquires over a month as they do not acknowledge or respond in a real world time frame (okay, my version of real world).         

Link to comment
Share on other sites

  • 2 weeks later...

I too have paid for and downloaded the UFile 2020 program. Like most others, the exe file will not install on my Win 10 machine. I have sent numerous emails and had numerous phone conversations, even suggesting they refund my money if they can't fix it, and all I get is automated replies telling me to do what I have already done. This company has no right to be in business if this is the best they can do

Link to comment
Share on other sites

Hi Graeme and all. I had no issues with downloading and installing the Windows version. I am not a tech person at Ufile but maybe I could help, maybe not. After the download was finished did you direct the install to be within the "Program Files (x86)" folder? Also is your firewall set to allow the program to be installed? It is always best to do the install as an Administrator. I use Google Chrome and the install was seamless. Sometimes there is a window popup that appears that requires consent based on various browsers. It appears that the majority of users have no issues so it may be related to settings that are specific to individual users systems.

Not sure if that can help, however please don't shoot the messenger. LOL

Link to comment
Share on other sites

I wrote earlier about the installation problem and am now happy to say I solved it. It seems all the protective software on my computer was either blocking part of the exe file coming in or else not recognizing it when I tried to run it from my downloads folder. So here's what I did:

1. Uninstalled System Mechanic completely just in case it was messing with it (but I still had the “raw materials” of it in my downloads folder).
2. Disabled all the protection in McAfee. At this point I still could not change the Windows settings, so I presume that once McAfee was there then Windows just turned over all the protection to McAfee, so it didn’t matter what I tried to tell Windows to do.
3. Downloaded once again the pgm from UFile (the .exe file already in the downloads folder had obviously got buggered up by all the virus protection stuff or else part of it never made it through).
4. Ran the .exe file and IT WORKED!
5. Reinstalled System Mechanic
7. Turned back ON the protective measures in McAfee
8. Poured myself a drink to celebrate.
The puzzling thing is that I never had to do this in all the years as far back as 2016, on the SAME COMPUTER.

Link to comment
Share on other sites

I am having the exact same problem as everyone else: This programme will NOT install on Windows 10 Home.

How it plays out: I successfully download the UFile 2020 for Windows file (ufile2020.exe).  I click on the programme, and it begins its installation routine.  Programme extracts... I get the installation wizard... I accept the terms of the licencing agreement... give permission for it to be installed in its default destination folder, and click "Install".  The programme starts to install... a popup asks if I wish to give permission for this programme to install, I click "Yes".  I briefly see the installer popup showing "Verifying Files", then everything totally disappears.  The "UFile2020" folder does not get created; the entire installation just stops and disappears without a trace.
I am using the latest, fully updated version of Windows 10 Home.
I have sent two emails to UFile about this problem, but have only received an automated reply (once).  It appears that UFile is not interested in fixing the problem or addressing their customer's concerns.
I notice here on the Comments Board that many people are experiencing the same problem.  People are pissed off with the automated replies, and want an answer/fix.  Like many others, I have been using UFile for many years, and like everyone else, I want to hear from A REAL PERSON with a solution as soon as possible.
Link to comment
Share on other sites

Good afternoon everyone.  I have found a workaround to get the UFILE2020 program installed without too much additional work.  With the latest version of Windows 10, if you are logged onto Windows with your regular account (even though you may have administrator privileges), something is blocking the program from installing.  To install it you need to log-on as the built-in Windows 10 administrator.

When you initially set-up Windows 10 on your computer, the administrator account is disabled, so you don't see it as a choice on the log-in screen.  You need to activate the built-in administrator account.  It is a pretty simple process.

  1. Right click on the Windows start icon, which will open a pop-up window
  2. Click on Command Prompt (Admin) to open the command screen.  If you only have Command Prompt to select from, pick that and select "Run as Administrator"
  3. In the command screen type:    net user administrator /active:yes    press ENTER
  4. To set the administrator password, type:  net user administrator *    press ENTER
  5. You will be prompted to enter a password and once you do that and press enter you will need to re-enter the password to confirm it
  6. You can close the command window
  7. Right click on the Windows start icon again and select SIGN OUT from the pop-up menu
  8. Windows will sign you out and the log-in screen will appear, showing both the Administrator and your normal user name
  9. Sign-on as Adminstrator.  Windows will set-up a new user, which will take 5 - 10 minutes
  10. Go to the UFILE site and download the program again (It won't be in the DOWNLOADS because the DOWNLOADS folder is associated with the current user account that is logged-in.
  11. Install the program and activate it.
  12. Sign out of the Administrator account and log-on to your regular account
  13. When you open the UFILE2020 program from your account you will need to activate it again, since it detects a "new" user.

I hope this is a help to everyone.


Link to comment
Share on other sites

Hey RandyD. Nice post. I had no issues with downloading and installing the program. I am using Windows 10 Pro. What Windows version are you using? That information might help other users. Earlier I posted that users should always install as an Administrator. There may be a problem with the Windows 10 Home version with popups blocking the install and a specific background registration file in the Windows 10 system files has to be disabled on each users system. That problem does not seem to exist on the Pro version. Just a thought. 

Link to comment
Share on other sites

It seems that there are issues with the online download veresion.  In the past when you purchased the program, you got the CD to use.  The installs were problem or issue free.  I purchased mine online from Staples.  I have now requested the CD to avoid using all the noted work arounds.  I am old school when it comes to downloading Tax software.

Link to comment
Share on other sites

  • 2 weeks later...

Hey all:

RandyD's second instruction, opening up the command processor as administrator, is key to being able to add that Administrator logon.  Once that has been set up and you've completed RandyD's procedures, everything works just fine.

However, what I really want to know is, why is this happening?  The guys at UFile have suddenly gone quiet, as far as responding to emails goes (although not, of course, as far as selling new copies of the software is concerned).  Their automated reply system to any email sent is useless, and my return email telling them how useless it is and asking for contact from a real live human being has gone unanswered. Maybe there are no human beings left at the company.

I don't see why I should stick with this software for next year's tax filing, and I may even switch to a different package for this year, given that this is the way this company treats its clients.

Edited by Nigel B
Correct typo
Link to comment
Share on other sites

  • 1 month later...

Tried installing ufile2020.exe. Says unzipping and then dissapears then nothing! Tried administrator, nothing! Tried looking for unzipped folder, nothing! Tried unzipping with Winzip, nothing!

Thought it was Windows 7 so upgraded to win10

Noticed it was zipped with 7-zip so downloaded that  and unzipped it into a folder. Worked!


You are welcome UFile!! Anymore issues and this long time user may just quit on you!! Should be free with the hassle it brings!!

Link to comment
Share on other sites

  • 3 weeks later...

Thanks, Pedro, that was the clue I needed. However setup.exe didn't work, so I right-clicked on Ufile_2020.msi (the *.msi file is the actual installer.). No joy.

So I clicked on MSXML4SP2.msi, which asked to update NVIDIA Web Helper. OK, and Ufile installed. I tested it, came up with request for activation key. Looks like it will work as desired.

I have a brand new MSI Trident (not for gaming. but for the graphics card). Looks like any system other than plain vanilla hardware will present problems.

Link to comment
Share on other sites

  • 11 months later...

If my computer crashed last year and the ufiles were lost is there any way of retrieving them (the tax return figures). If I download the 2020 ufile again with my activation key will those files be there too or just the program

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...