Jump to content
Français

Unable to log on or retrieve password


twalk
 Share

Recommended Posts

I am unable to login as the site states that my password is incorrect even though I know it's right. I then get a message asking for my "phrase"... I don't have a phrase. I then try to reset my password, but it asks for my receipt number which I do not have. I then reach out to UFile support and received the message "You will receive a new email from our company in maximum 15 minutes..." I never received this email.  I had this exact same problem last year and it took several weeks to rectify. Hopefully it will be quicker this time. 

 

Link to comment
Share on other sites

Hi for your security we always request that in setting up your account you provide a security question with an answer just in case you lose or forget your password. As a secondary measure if you didn't set-up a security question then we default to asking you to provide your receipt number which we provided when you paid for the previous year's income tax return. The email to confirm your password reset may take more than 15 minutes to arrive depending on how busy the server may be, and you need to check your junk folder too.

There is not much more we can do without compromising your account security. You have the option to contact our support department, or start a new account. Most of your carry-forward amount are on file with the CRA so you have nothing to lose if you are pressed for time. 

Kind regards, George Hiotis [QA Manager - UFile.]

Link to comment
Share on other sites

  • 1 month later...

A few years ago, I went through the same issues as twalk: Ufile would not accept my pw and then asked for the answer to a safe Question. However, when I enrolled years before, there was no safe question to enter. So they changed their security system but did not contact clients like me who did not have any. So I finally managed to get it solved. But now (in 2022), today, I tried to log in and my pw does not work even though I know it is the correct one as I keep this information. I tried on 2 webbrowers (Chrome and Firefox on Mac Catalina), I reset my pw twice. And still I am getting an error message. It seems to be common with Ufile. I have been with them since 2009 but seriously, I am so close to switch to another system. They don't seem reliable to me anymore.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...