Jump to content

Unable to connect with CRA server


Recommended Posts

I cannot connect to the CRA server through ufile netfile.  It simply says 'error connecting to CRA server'.  But when installing Ufile 2021 in the first place, it came up with an istallation error '1612'.  So I suspect that this installation error is prohibitting UFile 2021 from connecting to the CRA Server to download the tax files.  Does anyone have any experience with this issue?

Link to comment
Share on other sites

Me too. I am having the same issue, tried several days in a row now.  Could someone from Ufile provide help on this topic? What should be done?

I am developer; I did a test on a clean Windows 10 virtual machine, and it worked fine. So it IS a problem in uFile software - it cannot handle settings in my laptop, but it works fine on the VM.

What's special in my laptop? Nothing. I have tried everything I can think of, but it just didn't work. uFile never executed the browser successfully because I never saw the browser UI.

Link to comment
Share on other sites

What I have tried:

1. make sure my Windows 10 Pro has the latest update, ufile has the latest update.

2. Edge is working properly

3. Set Edge as default browser, uninstaller Internet Explorer 11 (both are unnecessary based on the test on my VM, though)

4. removed all other Edge profiles, only leave the default profile, not signed on

5. removed all extensions in Edge

6. Clear ALL cache in Edge

7. Reset Edge settings to default

So my Edge is practically like fresh

8. make sure I don't have VPN, and internet connect is working

* make sure Edge works fine, close and restart ufile app, try again.

* Restart my laptop, and try again.

Nothing works so far.





Edited by Jeffrey 425354
give more details
Link to comment
Share on other sites

oh my god. finally fixed it. @ufile team, please send this to your dev team, they may find a fix from code, at least give a meaningful error message and a tip.


find error message in event log

A fatal error occurred while creating a TLS client credential. The internal error state is 10013.


Windows+R, run "inetcpl.cpl"

go to Advanced > Scroll down to Security and note the TLS settings. Make sure check "Use TLS 1.2"

or, for most users, you can simply click "Restore advanced settings".

(see screenshot)


Link to comment
Share on other sites

  • 5 months later...

I tried this fix, but it didn't work for me. Am I to understand that there has been ZERO response from UFile to the people here saying they can't connect to the CRA? I am in an extremely difficult financial situation and I literally had to go without two meals to afford this software. I bought it because I've been using it since 2015 and I thought it would make this stressful chore easier for me. Instead, it's made it more stressful. I would like a refund, as I cannot file my taxes without being able to use Auto-fill.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...